苹果:4月起所有新应用必须适配iPhone X

苹果公司已通知应用开发人员,今年4月起,所有提交到App Store的新应用必须适配iPhone X的超级视网膜显示屏。也就是说,开发人员必须保证新应用的界面,依据iPhone X刘海设计,并能充满5.8英寸的OLED屏。

关于已上线的应用何时必须适配iPhone X,苹果公司没有给出严格规定。但自4月起,所有新应用必须基于iOS 11开发包来开发。

近年来,苹果对软件是否适配新设备的要求越来越严格。

苹果公司在邮件中表示,鼓励新应用支持包括Core ML、SiriKit和ARKit在内的iOS 11新特色。而基于iOS 11开发包进行开发,并不意味着新应用必须支持这些新特色。

苹果的新规定可以带动App Store中的软件升级,同时提高iOS 11新功能的使用率。

但是,如果苹果公司不对已上线的应用做出严格规定,要求这些应用也必须适配iPhone X、必须采用iOS 11开发包进行开发,那新规定的效果可能不会非常明显。毕竟大多数开发新应用的开发人员,开发时针对的设备已经是iPhone X了。

据说喜欢分享的,后来都成了大神:爱玩手机网 » 苹果:4月起所有新应用必须适配iPhone X

评论 0

文章评论已关闭!